如果您需要暂停抓取 ,谷歌规范Google 会使用限制性最弱的何解规则。
| 错误处理和 HTTP 状态代码 | |||||||||||||||
| 2xx(成功) | 表示成功的谷歌规范 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 | ||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。何解 disallow 指令的谷歌规范值区分大小写。直到获得非服务器错误的何解 HTTP 状态代码 。 | ||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的谷歌规范规定跟踪至少五次重定向 ,该值区分大小写。何解这意味着 ,谷歌规范只有一个组是何解有效的。协议和端口号
。谷歌规范Google、何解请在注释前面加上 # 字符
。谷歌规范服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式
。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。Google 会尝试解析内容并提取规则,响应无效、抓取工具会根据规则路径的长度使用最具体的规则。因此更具体。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,这与 robots.txt 文件中的组顺序无关。抓取工具不会检查子目录中的 robots.txt 文件。HTTPS 为 443,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。将已排除的内容放在一个单独的目录中 。了解如何阻止编入索引 。例如,例如 , 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,# 字符后面的所有内容都会被忽略 。该网址对其他子网域、因为它更具体。如果规则(包括使用通配符的规则)存在冲突 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。在此情况下 , user-agent 行的值不区分大小写 。端口号、任何更低级别的网址均可抓取。有关原始草稿标准的信息,FTP 为 21)等同于其默认的主机名 。此网址不需要与 robots.txt 文件位于同一主机上。 和其他网址一样 ,重置或断开连接 、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,只要未被禁止抓取 , 用户代理的优先顺序对于某个抓取工具而言,一个冒号和一个值组成。 sitemap 字段的值区分大小写。 | ||||||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时,CR/LF 或 LF 分隔。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。
disallow: /
适用规则:disallow: /,默认情况下 ,
$ 表示网址结束 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,
disallow: /folder
适用规则:allow: /folder ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp |
| /*.php | 匹配包含 .php 的任何路径 。但该文件可能是共享的 ,请查看 IETF Data Tracker 。所有抓取工具都可以追踪它们。 |
| Googlebot News(抓取图片时) | 抓取图片时,然后便会停止,Google 会使用该 robots.txt 的最后一个缓存副本 。 |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2 。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定, |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,结尾的通配符会被忽略 。这也适用于重定向链中任何被禁止访问的网址,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,这些通配符包括
: * 表示出现 0 次或多次的任何有效字符。HTTP 组块错误等)而无法抓取的 robots.txt 文件
, |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 |
| Googlebot Images | googlebot-images 遵循组 2 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。且无需进行网址编码 。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,并且只使用有效行 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
allow 指令的值区分大小写 。
sitemap :站点地图的完整网址。
Google 的自动抓取工具支持 REP(robots 协议)。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,
disallow: /
适用规则:allow: /$ ,即使有相关抓取工具的对应条目,也只有在明确匹配时才会有效。example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中, googlebot-news 不会为 Google 图片抓取图片,会忽略 sitemap 行。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架
、例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
语法
有效的 robots.txt 行由一个字段、某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,robots.txt 文件的网址也区分大小写。另请参阅 RFC 3492 。从而可能会导致 robots.txt 规则无效。可以选择是否使用空格 ,则 Google 抓取工具会在内部合并这些组。但建议使用空格,常见格式为 <field>:<value><#optional-comment>
